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Objectives


To explain the workings of the SIETE Module template


To give documents a consistent look.


To make global changes to all documents easier.


To allow documents to be formatted across platforms easier.


Introduction


Microsoft Word 6.0 and many other word processors give the user the ability to use templates.  Templates make it possible to reuse document styles and formats that a word processor uses easily and consistently.  This allows the author to give distinguished looks to documents depending on his needs, without spending a lot of time switching fonts and paragraph settings.  


The author may have a template for business letters and a template for casual letters.  When the author composes the letter he applies styles to different parts of the document, such as: the address, date, greeting, body, closing, and salutation.  The template defines how each of these styles will appear in the letter.  The business letter may have different spacings and fonts than the casual letter, and the author can totally reformat the look of his document with just a few simple keystrokes from one template to the other.


The Summer Institute for Technology Education (SIETE) uses a document template with some useful macros and styles that make it easy to give the modules and experiments a consistent look.  This document will explain the workings of this template, and some general rules you should follow to make later editing of the documents quick and easy.  The name of the template is module.dot and should be placed in your winword\templates directory before editing a SIETE document.  If you are saving your files on a floppy, the template file (module.dot) may be kept on the floppy in the root directory, but will not be run unless module.dot does not exist in Word’s template directory.  In Word check the Template option under the File menu (Alt-F, T) to see which template you are using.


This instructional document will be broken up into the following sections:


Basic definitions and uses of Styles and Macros.


Converting a document from another source to the SIETE template.


Writing a New SIETE document.


Editing an existing SIETE document.


General Rules for Editing


Definitions in Module.dot


Module.dot is the MS Word 6.0 template that is used for all of the modules and introductions in SIETE documentation.  


NOTE:	You must set the document to the module.dot template for any styles and macros mentioned in this document to work.


Once the document’s template is set to module.dot the SIETE menu item will appear on the menu-bar.  Most of the macros and styles explained here will be listed there.


Some Handy Macros for Styles:


ALT-2	Sets Line to Heading Level 2 ('Concept', 'Objectives', etc.)


ALT-3	Sets Line to Heading Level 3 ('Grades 9-12:', etc.) (Converts text to Title case)


Alt-B	Sets Paragraph to type Body.  Used for all normal text.


Alt-L	Sets Paragraph to type List (Use for Numbered lists.)  (For Numbered Lists: After setting to type list, highlight numbering selection and press the AUTO-NUMBER button on the button bar.)


Alt-U	Sets to Bullet List for using standard bullets.


Alt-R	Use of Bibliography information and other References.


CTRL-SHIFT-K	Small Caps: use for author names in References. Used as a toggle or to convert selected text.


CTRL-I, CTRL-B, and CTRL-U	Apply Italics, Bold, and Underlines respectively.


Setup SIETE Module Type...


�


Figure � SEQ Figure \* ARABIC �1�:  SIETE Module Options dialog box


The use of the SIETE Module Template macros has been significantly simplified and automated with the use of the SIETE Module Options dialog box, � REF _Ref332168582 \* MERGEFORMAT �Figure 1�.  This box is run automatically upon creation of a new SIETE file based on the template, or on opening of a file created with an older version of the module.dot template.  This command should be run at least once or other macros may not work correctly.


Steps for Standard Dialog Use:


Select Module Type


Enter Title of Document


Enter Subject of Document


Enter Module number of Document


Select [OK].


Allow about 10s for the macro to finish executing.


The SIETE Module Type... dialog box controls many macros that are associated with the template that automatically perform many document layout tasks.  Some of these macros use Document Variables to determine what you have classified the Module as: Introduction, Teacher, or one of the Student versions.


For these macros to enter the correct data the appropriate fields must be set in the Summary Information dialog box under the File menu.  The Update All Fields command under the SIETE menu will insert the summary information into the headers and title.


The SIETE Module Options dialog box automatically sets the Summary Information, places the appropriate title and headers based on the document type, and then updates the document.  Pressing OK will always update the document with the stored summary information, but you may choose not to have it replace the title or headers by deselecting the appropriate checkbox.  Because long title and subject names may cause crowding in the header, the macro automatically chooses a smaller font if there are too many characters in the header.
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Figure � SEQ Figure \* ARABIC �2�:  SIETE Module Menu


Update All Fields In Document


This macro updates the fields in the document with the current information in the Summary Info dialog box found under the File Menu.  The SIETE Module Type... will automatically execute this function, but manual changes may be updated with it as well.  The values which are automatically entered in the fields are:


Title:		Set to Title of Module


Subject:		Set to Engineering Discipline (e.g., 'Electrical Engineering')


Keywords:		Set to Module Number (e.g., '1’, ‘2’, etc.) or ‘Introduction’


This macro may take 5 to 10 seconds to finish executing.


Edit Summary Info...


Provides access to the same dialog box found under the File Menu.  The document title, subject, and module number are taken from the summary field data.


Auto SaveAs Name...


This is a useful macro that automatically names the document to the standard SIETE DOS convention for you based on document information.  It chooses the root four character filename by examining the subject field of the document.  If your subject isn’t one it knows, it will ask you to enter a four character root.  Once the filename has be derived, it presents the user with a SaveAs dialog box.  Make sure the directory you are saving to is the appropriate directory.  Check the filename, and then press OK. 


Styles in Use:


The following styles are some of the more common template styles that should be used throughout the document.  


Body Text:		For normal typing.


List:			For Lists and Numbering	(also List 2, List 3, etc.)


List Bullet:		For Bullets (also List Bullet 2, List Bullet 3, etc.)


Endnotes:		For Bibliographies and references.


Header:		For non 1st page headers (normal size)


Header (small):	For non 1st page headers that have very long titles


Header (very small):	Even larger titles


Heading 2:		For Main Divisions (Introduction, Concept, Objectives, etc.)


Heading 3:		For Smaller Divisions under Heading 2


Address:	Use for addresses of organizations.  Press SHIFT-[Enter] after each line in address field, and a normal [Enter] for the last line.


Code:	Used for computer source code.


Screen Box:	Used to show example computer commands and printouts.


Converting Documents to the SIETE Template


Attach module.dot Template To The Document.


Templates... is found under the File menu.  Make sure to check the Automatically Update Document Styles box.  If you do not attach the template, none of the macros or styles will be available to you.


Run SIETE Module Type... dialog box


If you open a file based on the module.dot template that has not been setup with this dialog box, it will be automatically executed for you.  When it automatically executes it also attempts to replace title lines of older versions of the template.  If you are converting a document to this template from another platform such as WordPerfect, you will have to run the SIETE Module Type... macro to insert the correct headers and titles, and to adjust the page margins.  You may want to delete any previous titles from the first page of the document, because it will place its own there.  Headers should be automatically replaced, but if a problem occurs, delete the old headers and try again.


Auto SaveAs Name...


To help keep a consistent naming convention choose the Auto SaveAsName... macro to generate the file’s name.  Make sure you select the correct directory for your file, check the filename for errors, and then press OK.  Once your document has been saved, use the standard Save command to resave it later.  (Ctrl-S)


Converting Document To Appropriate Styles


This is the long and hard part.  All Headings, lists, bullets and text in the document need to be converted to their appropriate form.  The Highest heading number used in the documents is Heading 2.  Heading 1 is used only in the title.  Refer to the Definitions section of this document for the other applications of the styles.


Delete any extra Paragraph marks, spaces, and tabs in the document.  To see all paragraph marks and spacing marks, push the � EMBED MSWordArt.2 \s ��� symbol on the toolbar.  Do not use extra spaces instead of tabs and do not use tabs instead of the indent feature.  The headings and paragraphs are set to automatically add appropriate space before and after the paragraphs and headings.  If you need to edit the spacing of a specific paragraph, click on the right mouse button and select Paragraph.


Figures


To refer to figures in the document, use the Insert Caption option to name the figure.  (Frames may be placed around pictures to allow text to wrap around them.)  If the figure is referred to in the document, insert a cross-reference to that figure. (Alt-I, R)


Save Often


Make sure you save your document after any major changes to avoid loosing time and work in the case of a computer problem.


Writing a New SIETE Document


Writing a new SIETE document involves many of the same steps as Converting Documents to the SIETE Template.


Creating A New Document


From the File menu choose New.  Then, scroll down the list of templates to use until you reach Module.  Choose this template.  When you create a New Document, the SIETE Module Type... Dialog Box automatically is executed for you.  Select the Module Type, Enter the Title, Subject, and Module Number in the Box and press OK.  The macro may take 10 or 15 seconds to run.


Auto SaveAs Name...


To help keep a consistent naming convention choose the Auto SaveAsName... macro to generate the file’s name.  Make sure you select the correct directory for your file, check the filename for errors, and then press OK.  Once your document has been saved, use the standard Save command to resave it later.  (Ctrl-S)


Type the Rest Of the Document


Enter the rest of the document according to style conventions outlined above and in the Definitions section.  Also, refer to General Rules to Remember for some other guides. 


Editing an Existing SIETE Document


This is easy as far as setting up the document is concerned.  Most of the conversion work and headers are already set for you.  Please refer to the other sections of this document for more complete explanations.


Run SIETE Module Type... dialog box


If you open a file based on the module.dot template that has not been setup with this dialog box, it will be automatically executed for you.  When it automatically executes it also attempts to replace title lines of older versions of the template.  Headers should be automatically replaced, but if a problem occurs, delete the old headers and try again.  At any time during the editing, you may change the module type, its title, subject, or module number by running this macro.  All changes to the document will occur automatically.


Auto SaveAs Name...


To help keep a consistent naming convention choose the Auto SaveAsName... macro to generate the file’s name.  Make sure you select the correct directory for your file, check the filename for errors, and then press OK.  Once your document has been saved, use the standard Save command to resave it later.  (Ctrl-S)


Type the Rest Of the Document


Enter the rest of the document according to style conventions outlined above and in the Definitions section.  Also, refer to General Rules to Remember for some other guides. 


General Rules to remember


Use the template styles as much as possible so as to remain consistent for later changes.  Try not to use Font and Paragraph to edit the look unless absolutely necessary.


Do not use the space bar to line up text.  Use the column tools, paragraph indenting tools and tab tools.  Spaces do not line up text in the printed document the same way they do on the screen, or from printer to printer.  They are font dependent.


Do not use tabs and returns, when you should use columns or paragraph indents.  Some of the styles (e.g., List, List Bullet, etc.) automatically wrap the paragraph and indent as you type.  Do not do this manually.  It is very difficult to remove extra tabs and make global changes if you do.  If the styles available on the template do not meet your indenting needs (i.e. Body Text Indent), use the indent features on the Formatting toolbar (button 2 and 3 from the right), or as a last resort use the Paragraph... option available when clicking the right mouse button.


Do not use tabs to make columns, use the Columns... command in the Format menu. Column breaks may be added from the Insert menu.  The easiest way to make a column is to highlight all the text you want to go into the column and then click on the Column Toolbar Button or choose Columns... in the Format menu. 


Add captions to pictures, graphs, and figures from the Caption... option of the Insert menu.  If you reference the figure in the text, insert a cross-reference... also from the Insert menu.


Do not make any changes to the module.dot template unless it is absolutely necessary and you want all documents of that template to be subject to those changes.  When exchanging files be sure to pass on your modified template.  When the documents are edited without your modified template, they will not look the same.


Try to use the digital image scanners to scan in any pictures into your document,  cutting and pasting is not easier to manage.


Use the Word for Windows Help and Tutorials to get excellent help.
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